Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 4.0, 3.2, 3.1
    • Fix Version/s: 4.0, 3.2, 3.1
    • Component/s: Tool Image Gallery
    • Labels:
      None

      Description

      Andrey, please give this priority.

      When attempting to upload an image in author, there's a error (which is a label) and the image does not get uploaded.

      None of the methods to upload work at all (Single or multiple).


      Exception:

      019-11-27 06:07:18,168 WARN [ToolContentHandler] Unable to to uploadFilemedium_Screen Shot 2019-11-27 at 6.jpgRepository Exception: InputStream is required. Retry not possible.
      06:07:18,178 ERROR [request] UT005023: Exception handling request to /lams/tool/laimag10/authoring/saveMultipleImages.do: org.springframework.web.util.NestedServletException: Request processing failed; nested exception is java.lang.NullPointerException
      at org.springframework@4.3.12.RELEASE//org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:982)
      at org.springframework@4.3.12.RELEASE//org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.java:872)
      at javax.servlet.api@1.0.0.Final//javax.servlet.http.HttpServlet.service(HttpServlet.java:706)
      at org.springframework@4.3.12.RELEASE//org.springframework.web.servlet.FrameworkServlet.service(FrameworkServlet.java:846)
      at javax.servlet.api@1.0.0.Final//javax.servlet.http.HttpServlet.service(HttpServlet.java:791)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.ServletHandler.handleRequest(ServletHandler.java:74)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.FilterHandler$FilterChainImpl.doFilter(FilterHandler.java:129)
      at deployment.lams.ear//org.lamsfoundation.lams.web.filter.LocaleFilter.doFilterInternal(LocaleFilter.java:114)
      at org.springframework@4.3.12.RELEASE//org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:107)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.core.ManagedFilter.doFilter(ManagedFilter.java:61)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.FilterHandler$FilterChainImpl.doFilter(FilterHandler.java:131)
      at deployment.lams.ear//org.lamsfoundation.lams.web.session.SystemSessionFilter.doFilter(SystemSessionFilter.java:59)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.core.ManagedFilter.doFilter(ManagedFilter.java:61)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.FilterHandler$FilterChainImpl.doFilter(FilterHandler.java:131)
      at org.springframework@4.3.12.RELEASE//org.springframework.orm.hibernate5.support.OpenSessionInViewFilter.doFilterInternal(OpenSessionInViewFilter.java:151)
      at org.springframework@4.3.12.RELEASE//org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:107)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.core.ManagedFilter.doFilter(ManagedFilter.java:61)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.FilterHandler$FilterChainImpl.doFilter(FilterHandler.java:131)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.FilterHandler.handleRequest(FilterHandler.java:84)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.security.ServletSecurityRoleHandler.handleRequest(ServletSecurityRoleHandler.java:62)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.ServletChain$1.handleRequest(ServletChain.java:68)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.ServletDispatchingHandler.handleRequest(ServletDispatchingHandler.java:36)
      at org.wildfly.extension.undertow@14.0.1.Final//org.wildfly.extension.undertow.security.SecurityContextAssociationHandler.handleRequest(SecurityContextAssociationHandler.java:78)
      at io.undertow.core@2.0.13.Final//io.undertow.server.handlers.PredicateHandler.handleRequest(PredicateHandler.java:43)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.security.SSLInformationAssociationHandler.handleRequest(SSLInformationAssociationHandler.java:132)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.security.ServletAuthenticationCallHandler.handleRequest(ServletAuthenticationCallHandler.java:57)
      at io.undertow.core@2.0.13.Final//io.undertow.security.handlers.AuthenticationConstraintHandler.handleRequest(AuthenticationConstraintHandler.java:53)
      at io.undertow.core@2.0.13.Final//io.undertow.security.handlers.AbstractConfidentialityHandler.handleRequest(AbstractConfidentialityHandler.java:46)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.security.ServletConfidentialityConstraintHandler.handleRequest(ServletConfidentialityConstraintHandler.java:64)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.security.ServletSecurityConstraintHandler.handleRequest(ServletSecurityConstraintHandler.java:59)
      at io.undertow.core@2.0.13.Final//io.undertow.security.handlers.AuthenticationMechanismsHandler.handleRequest(AuthenticationMechanismsHandler.java:60)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.security.CachedAuthenticatedSessionHandler.handleRequest(CachedAuthenticatedSessionHandler.java:77)
      at io.undertow.core@2.0.13.Final//io.undertow.security.handlers.NotificationReceiverHandler.handleRequest(NotificationReceiverHandler.java:50)
      at io.undertow.core@2.0.13.Final//io.undertow.security.handlers.AbstractSecurityContextAssociationHandler.handleRequest(AbstractSecurityContextAssociationHandler.java:43)
      at io.undertow.core@2.0.13.Final//io.undertow.server.handlers.PredicateHandler.handleRequest(PredicateHandler.java:43)
      at org.wildfly.extension.undertow@14.0.1.Final//org.wildfly.extension.undertow.security.jacc.JACCContextIdHandler.handleRequest(JACCContextIdHandler.java:61)
      at io.undertow.core@2.0.13.Final//io.undertow.server.handlers.PredicateHandler.handleRequest(PredicateHandler.java:43)
      at org.wildfly.extension.undertow@14.0.1.Final//org.wildfly.extension.undertow.deployment.GlobalRequestControllerHandler.handleRequest(GlobalRequestControllerHandler.java:68)
      at io.undertow.core@2.0.13.Final//io.undertow.server.handlers.PredicateHandler.handleRequest(PredicateHandler.java:43)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.ServletInitialHandler.handleFirstRequest(ServletInitialHandler.java:292)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.ServletInitialHandler.access$100(ServletInitialHandler.java:81)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.ServletInitialHandler$2.call(ServletInitialHandler.java:138)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.ServletInitialHandler$2.call(ServletInitialHandler.java:135)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.core.ServletRequestContextThreadSetupAction$1.call(ServletRequestContextThreadSetupAction.java:48)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.core.ContextClassLoaderSetupAction$1.call(ContextClassLoaderSetupAction.java:43)
      at org.wildfly.extension.undertow@14.0.1.Final//org.wildfly.extension.undertow.security.SecurityContextThreadSetupAction.lambda$create$0(SecurityContextThreadSetupAction.java:105)
      at org.wildfly.extension.undertow@14.0.1.Final//org.wildfly.extension.undertow.deployment.UndertowDeploymentInfoService$UndertowThreadSetupAction.lambda$create$0(UndertowDeploymentInfoService.java:1502)
      at org.wildfly.extension.undertow@14.0.1.Final//org.wildfly.extension.undertow.deployment.UndertowDeploymentInfoService$UndertowThreadSetupAction.lambda$create$0(UndertowDeploymentInfoService.java:1502)
      at org.wildfly.extension.undertow@14.0.1.Final//org.wildfly.extension.undertow.deployment.UndertowDeploymentInfoService$UndertowThreadSetupAction.lambda$create$0(UndertowDeploymentInfoService.java:1502)
      at org.wildfly.extension.undertow@14.0.1.Final//org.wildfly.extension.undertow.deployment.UndertowDeploymentInfoService$UndertowThreadSetupAction.lambda$create$0(UndertowDeploymentInfoService.java:1502)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.ServletInitialHandler.dispatchRequest(ServletInitialHandler.java:272)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.ServletInitialHandler.access$000(ServletInitialHandler.java:81)
      at io.undertow.servlet@2.0.13.Final//io.undertow.servlet.handlers.ServletInitialHandler$1.handleRequest(ServletInitialHandler.java:104)
      at io.undertow.core@2.0.13.Final//io.undertow.server.Connectors.executeRootHandler(Connectors.java:360)
      at io.undertow.core@2.0.13.Final//io.undertow.server.HttpServerExchange$1.run(HttpServerExchange.java:830)
      at org.jboss.threads@2.3.2.Final//org.jboss.threads.ContextClassLoaderSavingRunnable.run(ContextClassLoaderSavingRunnable.java:35)
      at org.jboss.threads@2.3.2.Final//org.jboss.threads.EnhancedQueueExecutor.safeRun(EnhancedQueueExecutor.java:1985)
      at org.jboss.threads@2.3.2.Final//org.jboss.threads.EnhancedQueueExecutor$ThreadBody.doRunTask(EnhancedQueueExecutor.java:1487)
      at org.jboss.threads@2.3.2.Final//org.jboss.threads.EnhancedQueueExecutor$ThreadBody.run(EnhancedQueueExecutor.java:1378)
      at java.base/java.lang.Thread.run(Thread.java:834)
      Caused by: java.lang.NullPointerException
      at deployment.lams.ear//org.lamsfoundation.lams.tool.imageGallery.web.controller.AuthoringController.saveMultipleImages(AuthoringController.java:503)
      at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.base/java.lang.reflect.Method.invoke(Method.java:566)
      at org.springframework@4.3.12.RELEASE//org.springframework.web.bind.annotation.support.HandlerMethodInvoker.invokeHandlerMethod(HandlerMethodInvoker.java:180)
      at org.springframework@4.3.12.RELEASE//org.springframework.web.servlet.mvc.annotation.AnnotationMethodHandlerAdapter.invokeHandlerMethod(AnnotationMethodHandlerAdapter.java:440)
      at org.springframework@4.3.12.RELEASE//org.springframework.web.servlet.mvc.annotation.AnnotationMethodHandlerAdapter.handle(AnnotationMethodHandlerAdapter.java:428)
      at org.springframework@4.3.12.RELEASE//org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:967)
      at org.springframework@4.3.12.RELEASE//org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:901)
      at org.springframework@4.3.12.RELEASE//org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:970)
      ... 59 more

      2019-11-27 06:07:49,985 DEBUG [CheckCredentialTicketBeforeAdvice] Method workspaceExists Checking credential/ticket org.lamsfoundation.lams.contentrepository.service.SimpleCredentials@2088c618
      2019-11-27 06:07:49,992 DEBUG [WorkspaceDAO] Getting workspace for name sharedimageGalleryworkspace
      2019-11-27 06:07:49,994 DEBUG [WorkspaceDAO] Returning workspace org.lamsfoundation.lams.contentrepository.CrWorkspace@66ceda73[workspaceId=2,name=sharedimageGalleryworkspace]
      2019-11-27 06:07:49,997 DEBUG [CheckCredentialTicketBeforeAdvice] Method addFileItem Checking credential/ticket org.lamsfoundation.lams.contentrepository.service.SimpleTicket@695f169f[workspaceId=2,ticketId=1574820437531_20.4154964707800871]
      2019-11-27 06:07:49,998 DEBUG [SimpleRepository] Getting user from UserDTO - must have come from a normal request
      2019-11-27 06:07:50,025 DEBUG [FileDAO] Writing out file to /var/opt/lams/repository/26/1
      2019-11-27 06:07:50,036 DEBUG [CheckCredentialTicketBeforeAdvice] Method workspaceExists Checking credential/ticket org.lamsfoundation.lams.contentrepository.service.SimpleCredentials@70882423
      2019-11-27 06:07:50,037 DEBUG [WorkspaceDAO] Getting workspace for name sharedimageGalleryworkspace
      2019-11-27 06:07:50,038 DEBUG [WorkspaceDAO] Returning workspace org.lamsfoundation.lams.contentrepository.CrWorkspace@66ceda73[workspaceId=2,name=sharedimageGalleryworkspace]
      2019-11-27 06:07:50,038 DEBUG [CheckCredentialTicketBeforeAdvice] Method getFileItem Checking credential/ticket org.lamsfoundation.lams.contentrepository.service.SimpleTicket@695f169f[workspaceId=2,ticketId=1574820437531_20.4154964707800871]
      2019-11-27 06:07:50,263 ERROR [ResizePictureUtil] javax.imageio.IIOException: Bogus input colorspace
      2019-11-27 06:07:50,264 DEBUG [CheckCredentialTicketBeforeAdvice] Method workspaceExists Checking credential/ticket org.lamsfoundation.lams.contentrepository.service.SimpleCredentials@5431e82a
      2019-11-27 06:07:50,264 DEBUG [WorkspaceDAO] Getting workspace for name sharedimageGalleryworkspace
      2019-11-27 06:07:50,266 DEBUG [WorkspaceDAO] Returning workspace org.lamsfoundation.lams.contentrepository.CrWorkspace@66ceda73[workspaceId=2,name=sharedimageGalleryworkspace]
      2019-11-27 06:07:50,266 DEBUG [CheckCredentialTicketBeforeAdvice] Method addFileItem Checking credential/ticket org.lamsfoundation.lams.contentrepository.service.SimpleTicket@695f169f[workspaceId=2,ticketId=1574820437531_20.4154964707800871]
      2019-11-27 06:07:50,267 DEBUG [SimpleRepository] Getting user from UserDTO - must have come from a normal request
      2019-11-27 06:07:50,269 WARN [ToolContentHandler] Unable to to uploadFilemedium_Screen Shot 2019-11-27 at 6.jpgRepository Exception: InputStream is required. Retry not possible.

        Activity

        ernieg Ernie Ghiglione added a comment -
        Reassigning this to Marcino

          People

          • Assignee:
            marcin Marcin Cieslak
            Reporter:
            ernieg Ernie Ghiglione
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development