Uploaded image for project: 'LAMS Development'
  1. LAMS Development
  2. LDEV-2860

Video recording throws an exception while exporting

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4
    • Component/s: Tool Video Recorder
    • Labels:
      None

      Description

      to reproduce:

      1) Open author
      2) Chuck a video recorder activity into the canvas
      3) Save
      4) Export

      Ka-boom... exception is thrown


      2012-04-02 09:20:45,091 [http-localhost%2F127.0.0.1-8180-1:] ERROR org.lamsfoundation.lams.learningdesign.service.ExportToolContentService - VideoRecorder export tool content failed:java.lang.NullPointerException
      java.lang.NullPointerException
      at org.lamsfoundation.lams.tool.videoRecorder.service.VideoRecorderService.exportToolContent(VideoRecorderService.java:290)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:307)
      at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:182)
      at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:149)
      at org.springframework.transaction.interceptor.TransactionInterceptor.invoke(TransactionInterceptor.java:106)
      at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)
      at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:204)
      at $Proxy163.exportToolContent(Unknown Source)
      at org.lamsfoundation.lams.learningdesign.service.ExportToolContentService.exportLearningDesign(ExportToolContentService.java:625)
      at org.lamsfoundation.lams.learningdesign.service.ExportToolContentService$$FastClassByCGLIB$$d05ed216.invoke(<generated>)
      at net.sf.cglib.proxy.MethodProxy.invoke(MethodProxy.java:149)
      at org.springframework.aop.framework.Cglib2AopProxy$CglibMethodInvocation.invokeJoinpoint(Cglib2AopProxy.java:700)
      at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:149)
      at org.springframework.transaction.interceptor.TransactionInterceptor.invoke(TransactionInterceptor.java:106)
      at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)
      at org.springframework.aop.framework.Cglib2AopProxy$DynamicAdvisedInterceptor.intercept(Cglib2AopProxy.java:635)
      at org.lamsfoundation.lams.learningdesign.service.ExportToolContentService$$EnhancerByCGLIB$$1a5e9e8e.exportLearningDesign(<generated>)
      at org.lamsfoundation.lams.authoring.web.ExportToolContentAction.exportLD(ExportToolContentAction.java:113)
      at org.lamsfoundation.lams.authoring.web.ExportToolContentAction.execute(ExportToolContentAction.java:93)
      at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
      at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:236)
      at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
      at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.lamsfoundation.lams.web.filter.LocaleFilter.doFilterInternal(LocaleFilter.java:142)
      at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.springframework.orm.hibernate3.support.OpenSessionInViewFilter.doFilterInternal(OpenSessionInViewFilter.java:198)
      at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.lamsfoundation.lams.web.session.SystemSessionFilter.doFilter(SystemSessionFilter.java:69)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:235)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
      at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:190)
      at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:525)
      at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:92)
      at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126)
      at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
      at org.lamsfoundation.lams.integration.security.SingleSignOn.invoke(SingleSignOn.java:118)
      at org.lamsfoundation.lams.integration.security.LoginRequestValve.invoke(LoginRequestValve.java:71)
      at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:567)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:829)
      at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:598)
      at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
      at java.lang.Thread.run(Thread.java:662)
      2012-04-02 09:20:46,932 [http-localhost%2F127.0.0.1-8180-1:] DEBUG org.lamsfoundation.lams.learningdesign.service.ExportToolContentService - Learning design xml export success
      2012-04-02 09:20:46,933 [http-localhost%2F127.0.0.1-8180-1:] DEBUG org.lamsfoundation.lams.learningdesign.service.ExportToolContentService - No such directory (or empty directory):/usr/local/jboss-5.1/server/default/deploy/lams.ear//lams-www.war/secure/09ef76b43665648d01367035331e001c
      2012-04-02 09:20:46,933 [http-localhost%2F127.0.0.1-8180-1:] DEBUG org.lamsfoundation.lams.learningdesign.service.ExportToolContentService - Create export content target zip file. File name is vr1.zip
      2012-04-02 09:20:46,941 [http-localhost%2F127.0.0.1-8180-1:] ERROR org.lamsfoundation.lams.authoring.web.ExportToolContentAction - Unable to export tool content: org.springframework.transaction.UnexpectedRollbackException: Transaction rolled back because it has been marked as rollback-only

        Activity

        dronych Andrey Balan added a comment -
        works good both for empty video recorder and already containing video
        ernieg Ernie Ghiglione added a comment -
        Tested and closed. Thanks Andrey

          People

          • Assignee:
            dronych Andrey Balan
            Reporter:
            ernieg Ernie Ghiglione
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development