Uploaded image for project: 'LAMS Development'
  1. LAMS Development
  2. LDEV-2840

When importing a sequence, the imported sequence doesn't open automatically

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4
    • Component/s: Author
    • Labels:
      None

      Description

      Somewhere, not so sure where, we lost the feature that after uploading a sequence, author automatically loads it.

        Activity

        Hide
        ernieg Ernie Ghiglione added a comment -
        Tested and closed
        Show
        ernieg Ernie Ghiglione added a comment - Tested and closed
        Hide
        ernieg Ernie Ghiglione added a comment -
        so the issue here is the missing uniqueID.

        We had to reinstate it, but in order not to abolish LDEV-2792, then we use the userId instead of a randomly generated number. That way we can keep the .swfs cached by the browser and the automatically import of sequence works. (and we didn't have do modify flash!)

        All good now.
        Show
        ernieg Ernie Ghiglione added a comment - so the issue here is the missing uniqueID. We had to reinstate it, but in order not to abolish LDEV-2792 , then we use the userId instead of a randomly generated number. That way we can keep the .swfs cached by the browser and the automatically import of sequence works. (and we didn't have do modify flash!) All good now.
        Hide
        ernieg Ernie Ghiglione added a comment -
        ok, so further investigation shed some light into the issue... this has to do with the import_passon.swf.

        When a design gets imported, then the result.jsp embeds a import_passon.swf file that should tell the authoring.swf file to load a particular design:

        http://137.111.246.19:8080/lams/toolcontent/import_passon.swf?learningDesignID=12&uniqueID=1754843167

        However, this seems to not working after the last version of the authoring.swf was added. So this might have something to do with the uniqueID that was removed from author.swf.





        Show
        ernieg Ernie Ghiglione added a comment - ok, so further investigation shed some light into the issue... this has to do with the import_passon.swf. When a design gets imported, then the result.jsp embeds a import_passon.swf file that should tell the authoring.swf file to load a particular design: http://137.111.246.19:8080/lams/toolcontent/import_passon.swf?learningDesignID=12&uniqueID=1754843167 However, this seems to not working after the last version of the authoring.swf was added. So this might have something to do with the uniqueID that was removed from author.swf.

          People

          • Assignee:
            ernieg Ernie Ghiglione
            Reporter:
            ernieg Ernie Ghiglione
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development