Uploaded image for project: 'LAMS Development'
  1. LAMS Development
  2. LDEV-2839

Precompile JSPs so we can use JBoss with JRE 1.6

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4
    • Component/s: General, Tools
    • Labels:
      None

      Description

      Create an ant task that would precompile all the jsps in all modules so when instead of needing the full JDK (so the JSPS get compiled the first time they get used), they are already precompiled and can be run with JRE 1.6 instead.

        Activity

        ernieg Ernie Ghiglione created issue -
        ernieg Ernie Ghiglione made changes -
        Field Original Value New Value
        Component/s General [ 10012 ]
        Component/s Tools [ 10015 ]
        ernieg Ernie Ghiglione made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        ernieg Ernie Ghiglione made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            marcin Marcin Cieslak
            Reporter:
            ernieg Ernie Ghiglione
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development