Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4
    • Component/s: Admin, General
    • Labels:
      None

      Description

      I think we changed some code before that now is causing trouble with the "Login as" feature.

      To reproduce (you can test this in shaun):

      1) Login as sysadmin
      2) Go sysadmin menu
      3) Click on Find user, then click Show all users or find one of your liking
      4) Click on a users "Login as" link and you will be redirected to the login page with an error saying that the username/passwd is wrong


        Activity

        marcin Marcin Cieslak added a comment -
        Problem was caused by changes made for LDEV-2771 and LDEV-2719.
        A patch fixing it by reverting and removing some now unnecessary code was committed.
        Successful regression tests were made against all 3 JIRAs.

        But honestly, I would have difficulties to explain each login flow and why it is successful using current code.
        It would be good to dig through and document it in detail at some stage of planned LAMS clean up.
        ernieg Ernie Ghiglione added a comment -
        Tested and closed

          People

          • Assignee:
            marcin Marcin Cieslak
            Reporter:
            ernieg Ernie Ghiglione
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development