Uploaded image for project: 'LAMS Development'
  1. LAMS Development
  2. LDEV-2748

New CKEditor doesn't allow Wiki to save?

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4
    • Component/s: Tool Wiki
    • Labels:
      None

      Description

      I think the new CKEditor might have broken Wiki Authoring.

      To reproduce:

      1) Chuck a wiki activity into the Authoring canvas,
      2) open Wiki tool
      3) Edit wiki page
      4) Try to save and you get a javascript error that prevents from saving

      "Uncaught ReferenceError: doEditOrAdd is not defined"

        Activity

        marcin Marcin Cieslak added a comment -
        I cannot reproduce this error. I tried Firefox and Chrome and it is working fine in both.
        Can you check it again and provide more info on environment?
        ernieg Ernie Ghiglione added a comment -
        I tested this again and I have the same result. My environment: windows xp with FF 8.0.1 and 9.01.

        See picture attached.

        marcin Marcin Cieslak added a comment -
        Fixed by changing localised labels.
        ernieg Ernie Ghiglione added a comment -
        Thanks Marcin, I'll fix this in the i18n site.

        Ernie

          People

          • Assignee:
            marcin Marcin Cieslak
            Reporter:
            ernieg Ernie Ghiglione
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development