Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4
    • Component/s: Tools
    • Labels:
      None

      Description

      Most changes required for upgrade from old FCKEditor to CKEditor 3.x has been performed earlier.
      Several tools new in LAMS 2.4 still need some cleaning.
      There is also unnecessary code for FCKEditor that can be removed.

        Activity

        ernieg Ernie Ghiglione added a comment -
        Marcin, when trying to test wookie, this is what I'm getting now:

        02:13:05,222 ERROR [InsertTag] ServletException in '/pages/authoring/authoring.jsp': javax.servlet.jsp.JspException: org.apache.jasper.JasperException: /pages/authoring/basic.jsp(159,3) No tag "CKEditor" defined in tag library imported with prefix "lams"
        org.apache.jasper.JasperException: An exception occurred processing JSP page /pages/authoring/authoring.jsp at line 58

        55: module="authoring" />
        56:
        57: <%-- Page tabs --%>
        58: <lams:TabBody id="1" titleKey="button.basic" page="basic.jsp" />
        59: <c:if test="${sessionMap.mode == 'author'}">
        60: <lams:TabBody id="2" titleKey="button.advanced" page="advanced.jsp" />
        61: <lams:TabBody id="3" titleKey="button.instructions"


        Stacktrace:
                at org.apache.jasper.servlet.JspServletWrapper.handleJspException(JspServletWrapper.java:498)
                at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:393)
                at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:322)
                at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:249)
                at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
                at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
                at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
                at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:638)
                at org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:543)
                at org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:480)
                at org.apache.jasper.runtime.JspRuntimeLibrary.include(JspRuntimeLibrary.java:968)
                at org.apache.jasper.runtime.PageContextImpl.include(PageContextImpl.java:611)
                at org.apache.struts.tiles.TilesUtilImpl.doInclude(TilesUtilImpl.java:99)
                at org.apache.struts.tiles.TilesUtil.doInclude(TilesUtil.java:135)
                at org.apache.struts.taglib.tiles.InsertTag.doInclude(InsertTag.java:760)
                at org.apache.struts.taglib.tiles.InsertTag$InsertHandler.doEndTag(InsertTag.java:892)
                at org.apache.struts.taglib.tiles.InsertTag.doEndTag(InsertTag.java:462)
                at org.apache.jsp.layouts.tabLayout_jsp._jspx_meth_tiles_005finsert_005f1(tabLayout_jsp.java:230)
                at org.apache.jsp.layouts.tabLayout_jsp._jspService(tabLayout_jsp.java:153)
                at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
                at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
                at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:369)
                at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:322)
                at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:249)
                at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
                at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
                at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
                at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:638)
                at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:444)
                at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:382)
                at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:310)
                at org.apache.struts.action.RequestProcessor.doForward(RequestProcessor.java:1085)
                at org.apache.struts.tiles.TilesRequestProcessor.doForward(TilesRequestProcessor.java:263)
                at org.apache.struts.tiles.TilesRequestProcessor.processTilesDefinition(TilesRequestProcessor.java:239)
                at org.apache.struts.tiles.TilesRequestProcessor.processForwardConfig(TilesRequestProcessor.java:302)
                at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:241)
                at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
                at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
                at javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
                at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
                at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
                at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
                at org.lamsfoundation.lams.web.filter.LocaleFilter.doFilterInternal(LocaleFilter.java:142)
                at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)
                at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
                at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
                at org.springframework.orm.hibernate3.support.OpenSessionInViewFilter.doFilterInternal(OpenSessionInViewFilter.java:198)
                at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)
                at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
                at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
                at org.lamsfoundation.lams.web.session.SystemSessionFilter.doFilter(SystemSessionFilter.java:69)
                at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
                at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
                at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
                at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
                at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
                at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:235)
                at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
                at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:190)
                at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:525)
                at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:92)
                at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126)
                at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70)
                at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
                at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
                at org.lamsfoundation.lams.integration.security.SingleSignOn.invoke(SingleSignOn.java:125)
                at org.lamsfoundation.lams.integration.security.LoginRequestValve.invoke(LoginRequestValve.java:71)
                at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:567)
                at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
                at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330)
                at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:829)
                at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:598)
                at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
                at java.lang.Thread.run(Thread.java:662)
        Caused by: javax.servlet.ServletException: javax.servlet.jsp.JspException: org.apache.jasper.JasperException: /pages/authoring/basic.jsp(159,3) No tag "CKEditor" defined in tag library imported with prefix "lams"
                at org.apache.jasper.runtime.PageContextImpl.doHandlePageException(PageContextImpl.java:848)
                at org.apache.jasper.runtime.PageContextImpl.handlePageException(PageContextImpl.java:781)
                at org.apache.jsp.pages.authoring.authoring_jsp._jspService(authoring_jsp.java:333)
                at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
                at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
                at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:369)
                ... 72 more
        Caused by: org.apache.jasper.JasperException: /pages/authoring/basic.jsp(159,3) No tag "CKEditor" defined in tag library imported with prefix "lams"


        Could it be that the tag is missing or not referenced properly?
        marcin Marcin Cieslak added a comment -
        My bad, I didn't commit part of changes. Fixing it now.
        ernieg Ernie Ghiglione added a comment -
        Getting the same exception with lams_tool_bbb too.
        marcin Marcin Cieslak added a comment -
        My fault again... Fixing it now.
        marcin Marcin Cieslak added a comment -
        Old FCKEditor seems to be removed from all Tools.
        ernieg Ernie Ghiglione added a comment -
        Tested and closed

          People

          • Assignee:
            marcin Marcin Cieslak
            Reporter:
            marcin Marcin Cieslak
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development