Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Duplicate
    • Affects Version/s: 2.4, 2.3.6
    • Fix Version/s: 2.4, 2.3.6
    • Component/s: Tool Forum
    • Labels:
      None

      Description

      This is a very irritating error as it stops the exception that is thrown doesn't allow the user to continue.

      This is the excepting that is being thrown:


      org.springframework.jdbc.UncategorizedSQLException: Hibernate operation: could not
      execute query; uncategorized SQLException for SQL [select count(*) as col_0_0_ from

      tl_lafrum11_message message0_ where (message0_.uid in (select

      messageseq1_.message_uid from tl_lafrum11_message_seq messageseq1_ where

      messageseq1_.root_message_uid=?)) and message0_.update_date>(select

      timestamp2_.timestamp_date from tl_lafrum11_timestamp timestamp2_ where

      timestamp2_.message_uid=? and timestamp2_.forum_user_uid=?)]; SQL state

      [21000]; error code [1242]; Subquery returns more than 1 row; nested exception is

      java.sql.SQLException: Subquery returns more than 1 row Hide detail

      org.springframework.jdbc.UncategorizedSQLException: Hibernate operation: could not

      execute query; uncategorized SQLException for SQL [select count(*) as col_0_0_ from

      tl_lafrum11_message message0_ where (message0_.uid in (select

      messageseq1_.message_uid from tl_lafrum11_message_seq messageseq1_ where

      messageseq1_.root_message_uid=?)) and message0_.update_date>(select

      timestamp2_.timestamp_date from tl_lafrum11_timestamp timestamp2_ where

      timestamp2_.message_uid=? and timestamp2_.forum_user_uid=?)]; SQL state

      [21000]; error code [1242]; Subquery returns more than 1 row; nested exception is

      java.sql.SQLException: Subquery returns more than 1 row java.sql.SQLException:

      Subquery returns more than 1 row at



      This exception is being thrown because the tl_lafrum11_timestamp table contains two records for a specify user_id.

      I really don't know how to effectively reproduce this but I know that if I delete on of these records, then it work.

      So two options to fix this:

      1) Ensure that there's only one entry on this table (my prefer option)

      2) or at runtime (learner), if there are more than one rows being return, handle this properly (take jsut one) rather that throw this exception.

        Activity

        ernieg Ernie Ghiglione added a comment -
        Fixed by: LDEV-2662

          People

          • Assignee:
            dronych Andrey Balan
            Reporter:
            ernieg Ernie Ghiglione
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development