Uploaded image for project: 'LAMS Development'
  1. LAMS Development
  2. LDEV-2716

Duplicated entries in "Learner summary" table

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.5
    • Fix Version/s: 2.4, 2.3.6
    • Component/s: Tool Assessment
    • Labels:
      None
    • Environment:
      FF 6.0.2

      Description

      Create lesson with assessment tool.
      finish it as a learner.
      go to monitor.

      Sometimes (very rarely) when you double click on main table in order to see user details, secondary table ("Learner summary") gets populated with duplicated entries. so it starts containing 2 same sets of entries.


      note: it can be caused by latest FF or upgrading to jquery 1.5.1

        Activity

        ernieg Ernie Ghiglione added a comment -
        I think I've seen this before. Probably because there are two ajax calls, right?
        dronych Andrey Balan added a comment -
        done
        dronych Andrey Balan added a comment -
        and yeah, the problem was due to two Ajax calls when they get called almost concurrently
        dronych Andrey Balan added a comment -
        Implementation if this Jira for lams2_3_release had broken Date and time restriction feature(in monitor)
        dronych Andrey Balan added a comment -
        fixed
        ernieg Ernie Ghiglione added a comment -
        Tested and closed

          People

          • Assignee:
            dronych Andrey Balan
            Reporter:
            dronych Andrey Balan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development