Uploaded image for project: 'LAMS Development'
  1. LAMS Development
  2. LDEV-2691

Can't add questions after performing any ajax call

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4
    • Component/s: Tool Assessment
    • Labels:
      None

      Description

      1. Start adding new multiple choice question.
      2. Enter all required values.
      3. Add new option or switch any existing ones and you won't be able to add this multiple choice.

      The JS error says, "CKEDITOR.instances.question is undefined".

      Again, this issue is brought by the new CKEDITOR and affects only HEAD branch.

        Activity

        dronych Andrey Balan added a comment -
        CKEditor lost all FKEditor's simplicity.

        so now to make all CKEditors work I should
        - store all CKEditor references before doing Ajax call,
        - make this call (which will reload part of the page with some editors),
        - manually remove lost editors
        - manually reinitialize them again

        wtf, it is so complicated now
        dronych Andrey Balan added a comment -
        After introduction of new version of CKEditor the issue has started happening again.
        Although there is no JS error this time.
        dronych Andrey Balan added a comment -
        To replicate the issue simply do any manipulations with options (e.g. move it up/down, delete, remove)
        You'll see some CKEditors will just disappear.
        dronych Andrey Balan added a comment -
        fixed.

        What freaks me out about CKeditor is that they keep changing the way they handle reinitialization of editors. Each new version it's absolutely different. And we have to adjust the code to those changes. this is the 4th time I'm doing this (if counting FCKEditor in). arghh!
        ernieg Ernie Ghiglione added a comment -
        I'm very certain that this is not as bad as working with lams_flash!! :-(

        But I can feel your pain brother... hehehe.
        dronych Andrey Balan added a comment -
        lol
        Yeah, life is a cruel thing ;)
        ernieg Ernie Ghiglione added a comment -
        Can't reproduce, so this should all be good. Thank Andrey

          People

          • Assignee:
            dronych Andrey Balan
            Reporter:
            dronych Andrey Balan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development