Uploaded image for project: 'LAMS Development'
  1. LAMS Development
  2. LDEV-2669

Incorrect alert message shows when uploading files

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4
    • Component/s: Tools
    • Labels:
      None

      Description

      From Vito Trifilo:

      "We've run into the following problem with uploading an image using the "Share Resources" tool in LAMS, we're wondering if it's a known issue and any ideas you might have about resolving it.
       
      Problem is as follows:
       
      Access "Share Resources"
      Upload an image file using FCKeditor (WYSIWYG). Click the image icon and select "browse server".

      After choosing a file you get the following error:

      A file with the same name is already available. The uploaded file has been renamed to "image.png"

      This is despite the fact that there was no file available, and the image was uploaded normally with no rename needed."


      The file gets uploaded properly but there must be an erroneous double check that fails and therefore this message pops. Check javascript code.
      1. Chrome_mac.png
        75 kB
      2. FF_win.png
        69 kB

        Activity

        ernieg Ernie Ghiglione created issue -
        ernieg Ernie Ghiglione added a comment -
        Marcin, when you work on the CKEditor plugin for uploading files, can you look into this? This should be rather trivial
        ernieg Ernie Ghiglione made changes -
        Field Original Value New Value
        Assignee Ernie Ghiglione [ ernieg ] Marcin Cieslak [ marcin ]
        Fix Version/s 2.3.6 [ 10180 ]
        Affects Version/s 2.4 [ 10110 ]
        Affects Version/s 2.3.6 [ 10180 ]
        Priority Major [ 3 ] Minor [ 4 ]
        marcin Marcin Cieslak added a comment -
        I remember this issue in old FCKeditor, but it problem does not exist in new CKEditor, so no action is needed.
        marcin Marcin Cieslak made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        ernieg Ernie Ghiglione added a comment -
        Marcin, this is still showing for me with the latest from HEAD with Chrome.

        I also tried this with FF in windows and still getting the same message (see new pics)
        ernieg Ernie Ghiglione made changes -
        Resolution Cannot Reproduce [ 5 ]
        Status Resolved [ 5 ] Reopened [ 4 ]
        ernieg Ernie Ghiglione made changes -
        Attachment FF_win.png [ 12125 ]
        Attachment Chrome_mac.png [ 12126 ]
        marcin Marcin Cieslak added a comment -
        Previous comment about problem not existing in new CKEditor was incorrect.
        LAMS provides two upload servlets for CKEditor:

        LAMSUploadServlet is used when uploading an image or a link straight from CKEditor plugin. This servlet was corrected in other JIRA, like LDEV-2744.

        LAMSConnectorServlet is used when uploading a file using old FCKEditor filemanager. No free filemanager is available with new CKEditor, so we need to stick to the old code. This servlet was cleaned up and fixed so it does not show misleading information about file being renamed.
        marcin Marcin Cieslak made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        ernieg Ernie Ghiglione added a comment -
        Now we are cooking with gas! Thanks Marcin
        ernieg Ernie Ghiglione made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            marcin Marcin Cieslak
            Reporter:
            ernieg Ernie Ghiglione
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development