Uploaded image for project: 'LAMS Development'
  1. LAMS Development
  2. LDEV-2619

"Export forum topic attachment failed" exception on share resources export

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.4
    • Fix Version/s: 2.4, 2.3.5
    • Component/s: Tool Share Resources
    • Labels:
      None

      Description

      Import the following sequence.
      add lesson.
      go to monitoring.
      try to export portfolio.
      in logs you'll get
      WARN [ToolContentHandler] Unable to to save node null as the node cannot be found. Repository Exception: UUID is null, unable to find node. Retry not possible.
      ERROR [ExportServlet] Export forum topic attachment failed: org.lamsfoundation.lams.contentrepository.ItemNotFoundException: UUID is null, unable to find node.

      even if there is no attachments in the tool

        Activity

        Hide
        ernieg Ernie Ghiglione added a comment -
        Please Andrey, add the fix to 2.3.5 as well. Thanks
        Show
        ernieg Ernie Ghiglione added a comment - Please Andrey, add the fix to 2.3.5 as well. Thanks
        Hide
        dronych Andrey Balan added a comment -
        fixed
        Show
        dronych Andrey Balan added a comment - fixed

          People

          • Assignee:
            dronych Andrey Balan
            Reporter:
            dronych Andrey Balan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development