Uploaded image for project: 'LAMS Development'
  1. LAMS Development
  2. LDEV-2533

StoreLDServlet not receiving WDDX packet

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4
    • Component/s: Author, General
    • Labels:
      None

      Description

      Try to save a sequence get this error

      2010-03-11 10:20:17,135 DEBUG [AbstractStoreWDDXPacketServlet] Request /lams/servlet/authoring/storeLearningDesignDetails received packet length
      2010-03-11 10:20:17,167 ERROR [StoreLDServlet] Authoring error. input packet was
      Premature end of file.
      at com.allaire.wddx.DeserializerWorker.throwSAXException(DeserializerWorker.java:451)
      at com.allaire.wddx.DeserializerWorker.fatalError(DeserializerWorker.java:297)
      at org.apache.xerces.util.ErrorHandlerWrapper.fatalError(Unknown Source)
      at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
      at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
      at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
      at org.apache.xerces.impl.XMLVersionDetector.determineDocVersion(Unknown Source)
      at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
      at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
      at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
      at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
      at com.allaire.wddx.DeserializerWorker.deserialize(DeserializerWorker.java:320)
      at com.allaire.wddx.WddxDeserializer.deserialize(WddxDeserializer.java:110)
      at org.lamsfoundation.lams.util.wddx.WDDXProcessor.deserialize(WDDXProcessor.java:102)
      at org.lamsfoundation.lams.authoring.service.AuthoringService.storeLearningDesignDetails(AuthoringService.java:1788)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:592)
      at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:307)
      at org.springframework.aop.framework.ReflectiveMethodInvocation.invokeJoinpoint(ReflectiveMethodInvocation.java:182)
      at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:149)
      at org.springframework.transaction.interceptor.TransactionInterceptor.invoke(TransactionInterceptor.java:106)
      at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)
      at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:204)
      at $Proxy326.storeLearningDesignDetails(Unknown Source)
      at org.lamsfoundation.lams.authoring.web.StoreLDServlet.process(StoreLDServlet.java:77)
      at org.lamsfoundation.lams.web.servlet.AbstractStoreWDDXPacketServlet.doPost(AbstractStoreWDDXPacketServlet.java:109)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:637)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

      Wireshark shows servlet receiving the wddx packet, but AbstractStoreWDDXPacketServlet not being able to read it/pass it on properly.

        Activity

        jundirl Jun-Dir Liew added a comment -
        OpenIdFilter is the cause (see http://code.google.com/p/joid/source/browse/trunk/src/org/verisign/joid/consumer/OpenIdFilter.java), but adding /servlet/authoring/storeLearningDesignDetails to the filter's ignorePaths init parameter works. Possibly other issues exist with this filter and lams servlets?
        lfoxton Luke Foxton added a comment -
        I made an improvement to this. Instead of including the store ld servlet in the ingnorepaths i instead change the OpenID filter mapping to only map to the OpenIDServlet so it only runs for this path, thats the only time we need it since we can also rely on lams authentication to block requests.

          People

          • Assignee:
            ernieg Ernie Ghiglione
            Reporter:
            jundirl Jun-Dir Liew
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development