Uploaded image for project: 'LAMS Development'
  1. LAMS Development
  2. LDEV-2490

First two tools share content when authoring in IE on Windows

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4, 2.3.3, 2.3.1
    • Fix Version/s: 2.4, 2.3.4
    • Component/s: Author
    • Labels:
      None
    • Environment:
      Windows XP + IE6/IE8, Windows 7 + IE8, Flash 10, LAMS 2.3.x

      Description

      1. drag three of the same tool onto author workspace
      2. open the first, edit something
      3. open the second; it has the same content as the first (!)
      4. open the third; it's content hasn't changed as expected

      I've only reproduced this on Windows and IE. Firefox and Chrome don't have this problem on Windows. Ubuntu also doesn't have this problem. I've only tested Flash 10. LAMS 2.2 doesn't have this problem.

      Thanks to Paul Gagnon and NTU for raising this issue.

        Activity

        ernieg Ernie Ghiglione added a comment -
        tested with Flash 9 and IE6 and 7 and can't reproduce.
        jundirl Jun-Dir Liew added a comment -
        Could be just Flash 10 + IE...
        jundirl Jun-Dir Liew added a comment -
        Problem was IE occasionally caching the response from getToolContentID. Fixed
        ernieg Ernie Ghiglione added a comment -
        After lots of testing, Jun and I have managed to figure out (thanks to www.debugbar.com) that IE caches the call to the server that creates the new toolContentID. So we might be able to set no-cache on the response.
        ernieg Ernie Ghiglione added a comment -
        Tested and closed

          People

          • Assignee:
            ernieg Ernie Ghiglione
            Reporter:
            jundirl Jun-Dir Liew
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development