Uploaded image for project: 'LAMS Development'
  1. LAMS Development
  2. LDEV-2446

Scheduling a lesson won't start at the scheduled time

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.3.5
    • Fix Version/s: 2.4
    • Component/s: Monitor
    • Labels:
      None

      Description

      To reproduce:

      1) Add a lesson to a class,
      2) Go to advance settings and enable scheduling
      3) Put any time into the future
      4) Add lesson.

      You will see that even after the scheduled time has passed LAMS does not start the lesson.

      Not so sure if this is a problem with the quartz scheduler or not.

        Activity

        ernieg Ernie Ghiglione added a comment -
        Tested in demo.lamscommunity.org/lams
        ernieg Ernie Ghiglione added a comment -
        I did a test on this and the lesson started but not at the time that it was expected. Perhaps the JVM is on a different timezone as the server?
        lfoxton Luke Foxton added a comment -
        Could this be an issue with daylight savings and timezones?

        I noticed I scheduled a lesson to start at 12:08pm and in the database the scheduled start time was 13:08pm

        If this is the problem, this could be a hairy one to fix, since not all areas withing the same timezone have daylight savings, we would have to have a special implementation for each city which is not nice..... ideas?
        ernieg Ernie Ghiglione added a comment -
        We should work on LDEV-2531 before we tackle this issue. When LDEV-2531 is done, we are half way there on this one
        ernieg Ernie Ghiglione added a comment -
        Moving to 2.4
        dronych Andrey Balan added a comment -
        done as part of LDEV-2593
        ernieg Ernie Ghiglione added a comment -
        Test and closed. Thanks Andrey

          People

          • Assignee:
            dronych Andrey Balan
            Reporter:
            ernieg Ernie Ghiglione
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development