Uploaded image for project: 'LAMS Development'
  1. LAMS Development
  2. LDEV-2422

Exception when two separate users upload pictures

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.3.1
    • Fix Version/s: 2.4, 2.3.2
    • Component/s: Tool Image Gallery
    • Labels:
      None

      Description

      Have a look at the attached sequence. It uses an image gallery tool in which contributions from students are allowed.

      To replicate this exception:

      1.- Start a lesson
      2.- As learner1, upload a picture
      3.- As learner2, upload a picture and you get the exception shown in pic4

      1. Picture 4.jpg
        148 kB

        Activity

        dronych Andrey Balan added a comment -
        Done

        But here is another question:
        If I need to change tl_laimag10_imageGallery_item table (simply drop one of its columns)
        can I just change existing sql script (create_lams_tool_imageGallery.sql) or I should create new update script ?
        ernieg Ernie Ghiglione added a comment -
        Andrey, since the changes were only done in cvs HEAD and here's no system in production with this code, then there's no need to have upgrade script. so just change the existing create_lams_tool_imageGallery.sql accordingly.

        I'll get Jun-Dir to confirm just in case.
        jundirl Jun-Dir Liew added a comment -
        Image gallery is in 2.3, so we'll need to include an update script in head - for when a 2.3 server is updated to 2.4. The same goes for the lams2_3_release branch (if/when there is a 2.3.2).
        ernieg Ernie Ghiglione added a comment -
        It seems that this problem is *not8* on the 2.3 branch as it's caused by a modification done *after* 2.3 and only in head though.
        ernieg Ernie Ghiglione added a comment -
        Just re-edit the versions accordingly
        dronych Andrey Balan added a comment -
        need to include an update script in head
        dronych Andrey Balan added a comment -
        done
        ernieg Ernie Ghiglione added a comment -
        Tested and closed
        jundirl Jun-Dir Liew added a comment -
        just fixing affects: and fixed in: fields

          People

          • Assignee:
            jundirl Jun-Dir Liew
            Reporter:
            ernieg Ernie Ghiglione
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development