Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4
    • Component/s: Tool Voting
    • Labels:
      None

      Description

      Open up authoring window for Voting tool.
      Try to save tool and you'll get this exception:
      java.lang.NumberFormatException: null Hide detail
      java.lang.NumberFormatException: null at java.lang.Integer.parseInt(Integer.java:415) at java.lang.Short.parseShort(Short.java:120) at java.lang.Short.parseShort(Short.java:78) at org.lamsfoundation.lams.tool.vote.web.AuthoringUtil.saveOrUpdateVoteContent(AuthoringUtil.java:1290)


      also if you'd try to create new nomination then "Page Not Found " error will be shown

        Activity

        dronych Andrey Balan added a comment -
        there is also a JS error on the main authoring page.
        It says "document.getElementById("dataFlowNoneOption") is null"
        dronych Andrey Balan added a comment -
        mate, can you have a look on these issues please?


        frankly speaking I'm a bit afraid of looking deeper into the code of this tool ;))
        and you seem like a guru of Voting tool already ;)
        marcin Marcin Cieslak added a comment -
        Bugs were caused by my faulty implementation of DataFlowObjects - sorry!
        ernieg Ernie Ghiglione added a comment -
        Tested and closed

          People

          • Assignee:
            marcin Marcin Cieslak
            Reporter:
            dronych Andrey Balan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development