Uploaded image for project: 'LAMS Development'
  1. LAMS Development
  2. LDEV-2390

Empty individual report in Assessment tool monitor

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.4
    • Fix Version/s: 2.4, 2.3.5
    • Component/s: Tool Assessment
    • Labels:
      None

      Description

      Create LD with assessment tool.
      Start lesson and submit random answers.
      Then go to the tool's monitor screen.
      Double click on learner. And you will see the new window "User's history of responses"
      but all the table will be empty

        Activity

        dronych Andrey Balan added a comment -
        Hey Luke,

        can you please have a look on this?
        because it seems this problem was caused by this commit

        "LDEV-2368 Improving the assessment excel export for NPS

        added a question worksheet as well as a user worksheet, with the option to hide the user names from the worksheet"

        particularly by adding the following condition to AssessmentServiceImpl.java:
        " if (questionResult.getFinishDate() == null) { "



        so if we really need it?
        dronych Andrey Balan added a comment -
        fixed
        ernieg Ernie Ghiglione added a comment -
        Tested and closed 2.4 and 2.3.5

          People

          • Assignee:
            dronych Andrey Balan
            Reporter:
            dronych Andrey Balan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development