Uploaded image for project: 'LAMS Development'
  1. LAMS Development
  2. LDEV-2329

When editing in monitor if press the "Cancel" button, the define_later flag does not get removed.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.4
    • Component/s: Tools
    • Labels:
      None

      Description

      To reproduce:

      see http://lamscommunity.org/dotlrn/clubs/technicalcommunity/forums/message-view?message_id=782519

      We probably need to check *all* other activities as it might be happening with others as well.

        Activity

        ernieg Ernie Ghiglione created issue -
        ernieg Ernie Ghiglione made changes -
        Field Original Value New Value
        Assignee Anthony Sukkar [ asukkar ] Andrey Balan [ dronych ]
        dronych Andrey Balan made changes -
        Component/s Tools [ 10015 ]
        Component/s Tool Noticeboard [ 10016 ]
        Fix Version/s 2.3.5 [ 10170 ]
        dronych Andrey Balan added a comment -
        done for both branches
        dronych Andrey Balan made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        dronych Andrey Balan added a comment -
        fixed typo in "if" clause
        ernieg Ernie Ghiglione added a comment -
        Tested and closed for 2.4 and 2.3.5.
        ernieg Ernie Ghiglione made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        ernieg Ernie Ghiglione added a comment -
        Reopenning as JIRA status shows as resolved but not closed, when it's actually closed... closing straightaway
        ernieg Ernie Ghiglione made changes -
        Resolution Fixed [ 1 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        ernieg Ernie Ghiglione made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        dronych Andrey Balan added a comment -
        It stopped working in Chrome.

        The problem is due to doCancel() method of AuthoringButton.tag (http://code.lamsfoundation.org/fisheye/browse/lams/lams_tool_forum/web/WEB-INF/tags/AuthoringButton.tag?r=1.14#l76).
        It assigns location.href= to the Lams action that should take care ab defineLater parameter.
        and then close current window
        window.close();

        But in current 17 version of Chrome if window is going to be closed it doesn't fire any events nor print documents as in provided link
        (http://stackoverflow.com/questions/7652981/chrome-window-print-window-close-results-in-print-preview-failed-solution).

        Easily can be proved by commenting out window.close(); Then everything works. Except closing current window, obviously
        dronych Andrey Balan made changes -
        Resolution Fixed [ 1 ]
        Status Closed [ 6 ] Reopened [ 4 ]
        ernieg Ernie Ghiglione made changes -
        Fix Version/s 2.3.5 [ 10170 ]
        dronych Andrey Balan added a comment -
        in 18th version of Chrome they just fixed print function, leaving location.href functionality untouched.
        so I came up with another approach.

        and it's fixed now
        dronych Andrey Balan made changes -
        Status Reopened [ 4 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        ernieg Ernie Ghiglione made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            dronych Andrey Balan
            Reporter:
            ernieg Ernie Ghiglione
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development