Uploaded image for project: 'LAMS Development'
  1. LAMS Development
  2. LDEV-1754

Able to remove learner from group even though grouping is used in a branching and the learner has done their branch

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.4
    • Fix Version/s: 2.4
    • Component/s: Monitor
    • Labels:
      None

      Description

      Set up a chosen grouping, and then grouped branching using the chosen grouping. Run this as a lesson.

      Add users to a particular group, then log in as one of the users and run through the design. Go back into the chosen grouping screen and you will find that you can still remove the users from the group and assign them to a new group.

      It doesn't do any "damage" in that any learner that has started on the branch will continue on the branch, but it will be confusing if you use the same grouping for two branches, or a branch and another activity as the learners may see different people in their group for the different activities.

      The problem is that the check to see if a user may be moved is based on the "mayBeDeleted" flag, which is based on tool sessions. But the mapping of the group to the branch isn't done via tool sessions (branching activities are complex activities so they don't have tool sessions). So the mayBeDeleted logic needs to be extended.

        Activity

        fionam Fiona Malikoff added a comment -
        Changing to 2.2. Potentially people may be a bit confused if they do this, but to lock it down so this doesn't happen will mean you can't change any learners once on start on branching, and that is seen as too broad a lockdown and isn't wanted done either.
        ernieg Ernie Ghiglione added a comment -
        This has been magically resolved as a result of LDEV-1978. Thanks Marcin!

          People

          • Assignee:
            ernieg Ernie Ghiglione
            Reporter:
            fionam Fiona Malikoff
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development