Uploaded image for project: 'LAMS Development'
  1. LAMS Development
  2. LDEV-1355

Creating a lesson returns empty xml

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.4
    • Fix Version/s: 2.1
    • Component/s: .LRN Integration
    • Labels:
      None

      Description

      When trying to create a lesson, LAMS returns an empty xml doco that tdom can't parse therefore throws this exception:

      error "no element found" at line 1 character 0
      while executing
      "dom parse $xml"
      invoked from within
      "set doc [dom parse $xml]"
      ("uplevel" body line 46)
      invoked from within
      "uplevel {
      # packages/lams2int/www/admin/add-2.tcl


      http://openacs.org/forums/message-view?message_id=1172569

        Activity

        ernieg Ernie Ghiglione added a comment -
        ernieg Ernie Ghiglione added a comment -
        Rob Mayhue from the .LRN community solved this by urlencoding the title and description.

        Thanks Rob!

        http://openacs.org/forums/message-view?message_id=1200107

          People

          • Assignee:
            ernieg Ernie Ghiglione
            Reporter:
            ernieg Ernie Ghiglione
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development