Uploaded image for project: 'LAMS Development'
  1. LAMS Development
  2. LDEV-1118

Add Mozilla 1.7 as a supported browser in the browser check

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 2.0
    • Fix Version/s: 2.4
    • Component/s: General
    • Labels:
      None

      Description

      Ken Kahn reports that JREX (built upon Gecko) works fine for LAMS, so we can probably allow it and other Mozilla based browsers through the browser check for the moment.

      From Ken Kahn:

      I changed the following (since it seems that my browser is detected as Mozilla 1.7)
      if(((moz_brow.indexOf("Firefox") != -1) || moz_brow.indexOf("Mozilla") != -1)

      && (moz_brow_nu >= 1.5)) return false; // Firefox 1.5+ or Mozilla 1.5+ (e.g.
      Gecko)

      inside of

      function isBrowserNotCompatable() {

      if(op) return true; // Opera

      else if(saf) return true; // Safari

      else if(ie6 || ie7) return false; // IE6 IE7

      else if(ie5xwin || ie5 || ie4 || ie5mac || ie5x) return true;

      else if(moz)

      if(((moz_brow.indexOf("Firefox") != -1) || moz_brow.indexOf("Mozilla") != -1)

      && (moz_brow_nu >= 1.5)) return false; // Firefox 1.5+ or Mozilla 1.5+ (e.g.
      Gecko)

      else return true;

      }

      in login.jsp

        Activity

        Hide
        ernieg Ernie Ghiglione added a comment -
        This is waaay tooo old
        Show
        ernieg Ernie Ghiglione added a comment - This is waaay tooo old

          People

          • Assignee:
            ernieg Ernie Ghiglione
            Reporter:
            fionam Fiona Malikoff
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development